shiva/profiles/base.nix
2024-06-09 15:38:32 +02:00

49 lines
967 B
Nix

{ pkgs, ... }: {
imports = [ ../modules/shiva ];
shiva.enable = true;
networking.hostName = "Shiva";
# Enables copy / paste when running in a KVM with spice.
services.spice-vdagentd.enable = true;
nix = {
settings = {
experimental-features = [ "nix-command" "flakes" ];
};
};
users.users.nixos.shell = pkgs.fish;
programs.fish.enable = true;
environment.systemPackages = with pkgs; [
bind.dnsutils
fd
git
gnupg
htop
mkpasswd
neovim-unwrapped
nixpkgs-fmt
tmux
wget
];
# Use faster squashfs compression
isoImage.squashfsCompression = "gzip -Xcompression-level 1";
nixpkgs.config.allowUnfree = true;
hardware.enableAllFirmware = true;
virtualisation.vmVariant = {
# following configuration is added only when building VM with build-vm
virtualisation = {
memorySize = 8192;
cores = 6;
graphics = true;
};
};
system.stateVersion = "24.05";
}